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Premessa. 
Questa guida propone un percorso semplificato per disegnare con Orcad lo schema 
elettrico ed il relativo circuito stampato concepito per la fotoincisione in qualità artigianale, 
cioè con piste e piazzole allargate. 
Si presuppone che il lettore sia in possesso delle conoscenze di base di Orcad dato che i 
comandi generali e/o quelli intuitivi vengono tralasciati per non appesantire 
eccessivamente questa trattazione. 
Si spiegherà come creare delle librerie per Orcad Layout, perché spesso si devono 
inserire nel circuito stampato dei componenti non contemplati nelle librerie del programma, 
librerie peraltro inesistenti nella versione demo di Orcad Layout. 
Alla fine ci sono alcune informazioni generali quali il significato delle estensioni più 
importanti ed un breve glossario. 
Questa guida fa riferimento ad una serie di files gestionali e di libreria creati per agevolare 
al massimo la realizzazione dei circuiti stampati con tecniche artigianali. 
La presenza del simbolo > evidenzia il passaggio da un menù ad un altro utilizzando il 
tasto sinistro del mouse, mentre la freccia → rappresenta il passaggio al menù successivo 
cliccando sul tasto destro del mouse per accedere ai cosiddetti menù di pop-up. 
 
 

          Disegnare con Orcad Capture.       .    
 
Impostazioni iniziali. 
Per Orcad9.2  verificare la presenza delle librerie in C:\Program Files\Orcad\Capture\Library 
Per Orcad10.3 verificare la presenza delle librerie in C:\Orcad\Orcad10.3\Tools\Capture\Library 
 
Alcune librerie, non tutte presenti nella versione demo di Orcad, sono le seguenti: 
discrete.olb R,C,L,led,display,pulsanti,etc.  counter.olb contatori digitali 
capsym.olb Vcc, GND, Title Block  misclinear.olb integrato NE555 
connector.olb connettori  regulator.olb stabilizzatori di tensione 
opamp.olb operazionali  transistor.olb transistori 
gate.olb porte logiche  caplib.olb nostra libreria personale 
 
 
Dal menù di avvio eseguire Orcad Capture. 
Cliccare su File>New>Project e selezionare 
Schematic; digitare un “Name” coerente col 
disegno in corso e sotto la voce Location digitare il 
nome della cartella che verrà creata per contenere 
i nostri file di lavoro. Ad esempio possiamo creare 
dei file di nome “Astabile” che andremo a collocare 
in “C:\PROGETTO” 
Per chiamare l’aiuto in linea utilizzare il tasto “F1” 
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Salvare periodicamente il lavoro cliccando sull’icona Save_Document. 
 

Su Option>Schematic Page Properties cliccare 
su Page Size e selezionare millimetri e A4. 
 
Se volete eliminare la squadratura da 
Option>Schematic Page Properties cliccare su 
Grid Reference e deselezionare tutte la caselle 
(tra loro allineate) di Border_Visible e di 
Grid_Reference_Visible. 

 
 
 
 
 
 
Con File>Print Preview>OK potrete 
vedere l’anteprima di stampa che vi 
mostrerà il foglio bianco con il cartiglio 
che conterrà i dati del disegno. 
Chiudete l’anteprima, fate scorrere il foglio per andare sul cartiglio e con doppio click sulle 
scritte tra parentesi digitate il titolo, mentre al posto di <Doc> conviene mettere i dati 

personali quali cognome e nome;  
come <Rev Code> digitate il numero 
di revisione del disegno. 
 
Per visualizzare il percorso del file 
fare doppio clic sul cartiglio>Design 

Name→Display, poi attivare Value Only > OK.  Il cartiglio può essere cambiato con 
Place>Title_Block, purchè sia stata caricata la libreria Capsym.olb 
Andare su Place>Part e verificare che l’elenco delle librerie caricate in memoria sia 
sufficiente per richiamare tutti i componenti che vi servono per fare il disegno. 
 
E’ bene non utilizzare le eventuali librerie appartenenti ad Orcad Pspice, perché spesso il 
numero di pin assegnato ai componenti non è compatibile con le librerie di Orcad Layout. 
 
Elenco librerie appartenenti a Pspice 
analog.olb componenti analogici  eval.olb porte, NE555, BJT 
Analog_p.olb R,C,L  source.olb sorgenti di segnale 
abm.olb stadi calcolatori  sourcstm.olb stimoli digitali 
breakout.olb circuiti integrati ADC,DAC,etc  special.olb simboli di visualizzazione 

 

Title

Size Document Number Rev

Date: Sheet of

IPSIA "L. Zanussi" 1

MULTIVIBRATORE ASTABILE

A4

1 1Wednesday , October 19, 2005

C:\PROGETTO\ASTABILE.DSN
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I componenti dello schema. 
Sempre con Place_Part si possono inserire tutti i componenti del disegno per poi 
connetterli con Place_Wire. 
Per inclinare un wire (es. vedere filo su anodo LED D1 dell’astabile) bisogna selezionarlo e 
poi trascinare col mouse il quadratino sul vertice mantenendo premuto il tasto Shift. 
Per assegnare un nome ad un wire andare su Place>Net_Alias; questa operazione è utile 
per individuare successivamente le corrispondenti tracce di connessione in Layout. 
Per selezionare più componenti con il mouse mantenere premuto il tasto Control. 
Assegnare ai componenti i reference ed i valori nominali adeguati cliccandoci sopra. 
Per verificare che i componenti usati siano compatibili con la libreria di Layout fare doppio 
click su essi, attivare la casella Pins in basso e verificare in particolar modo che il Number 
(dei pins del componente) siano numerati in modo progressivo da 1 in su. Se così non è 
selezionare il componente da modificare, cliccarci sopra con il tasto destro e selezionare 
Edit_Part; fare doppio click su ogni pin del componente e modificare il Number. 
 
 
 
 
 
 
 
 

Chiudere la finestra di Editor componenti (su croce chiudi) e  cliccare sulla finestra 
Update_Current per confermare le modifiche apportate al solo componente corrente. 
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Dopo il disegno… 
Dopo aver salvato il disegno e le ultime modifiche, cliccare sull’icona Project Manager 
(quella con il disegno delle cartelline), dalla cartellina SCHEMATIC1 selezionare PAGE1 
(ovvero il disegno) e cliccare sull’icona DRC (Design Rules Check). 
 

 
 
Abilitate la casella Create_DRC_Markers_for_warnings e date l’OK. Se non compare 
nessuna scritta è buon segno, perché non sono stati commessi errori grossolani e potete 
tornare sul disegno cliccando su PAGE1. In caso contrario verrà visualizzato un rapporto 
degli errori e sul disegno compariranno dei marcatori verdi. 
Per correggere eventuali reference doppi o mancanti, da Project_Manager cliccate su 
Annotate (icona con “U?”) e quindi, sotto la voce Packaging_Action, bisogna selezionare 
“Unconditional_reference_update”; infine cliccare su OK.  
 
Sempre da Project_Manager, con PAGE1 selezionato, cliccate sull’icona Bill of Materials e 
date l’OK per generare un file con estensione .bom che comparirà in elenco; cliccarci 
sopra due volte e stamparlo per avere la distinta dei componenti del disegno. Con la 
funzione copia-incolla del PC è possibile inserire l’elenco su un documento in Word. 
 
Creare la Netlist. 
il file netlist con estensione .mnl che servirà a Layout  per riconoscere i componenti 
necessari e le loro connessioni elettriche. Introdurre al max 15 componenti per Orcad 9.2 
Lite e max 10 componenti per Orcad 10.3 Demo! 
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Da Project_Manager cliccate sull’icona Create Netlist, selezionate la finestra Layout, e 
optate assolutamente per User_Properties_are_in_inc hes . 
Attivate l’opzione “Run_ECO_to_Layout” se si vuole forzare Orcad Layout a ricaricare la 
netlist ad ogni avvio recependo eventuali modifiche dello schema elettrico.  Dopo l’OK si 
vedrà comparire nell’elenco di progetto il file .mnl 
 
Stampare lo schema. 
Se desiderate copiare lo schema elettrico in un documento, ad esempio di Word, 
selezionate l’intero schema (con icona Select attiva, trascinando il mouse formate una 
finestra che racchiuda lo schema), andate in Edit>Copy (oppure Ctrl+C da tastiera), aprite 
un documento di Word ed incollate il tutto (Ctrl+V da tastiera). 
Naturalmente lo schema può essere stampato integralmente da Capture utilizzando 
nell’ordine i seguenti menù:  File>Print Preview,  File>Print Setup  e  File>Print. 
Per riaprire il disegno avviate Capture e quindi con File>Open>Project cercare il file .opj 
del progetto. Notare che nella parte bassa del menù 
“File” è possibile vedere l’elenco e richiamare i 
progetti aperti di recente.   
Se poi, anziché comparire lo schema, appare la 
finestra del Project Manager è sufficiente fare doppio 
click su:  \astabile.dsn>SCHEMATIC1>PAGE1 
 
Conservare lo schema. 
Se entrate nella cartella inizialmente creata 
nel disco locale C:\  compariranno diversi 
files: i più importanti, da non perdere, sono 
quelli con estensione .dsn (disegno con icona 
mappamondo) e .opj (progetto contenente i 
dati generali del lavoro, rappresentato con 
un’icona a forma di foglio celeste). 
Inoltre per utilizzare Orcad Layout avremo 
bisogno del file netlist con estensione .mnl 
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           Lavorare con Orcad Layout.        .    
    
Le librerie. 
Verificare la presenza delle librerie in C:\………\Orcad\Layout\Library 
Le più importanti, che non sono presenti nella versione demo di Orcad, sono le seguenti: 
Layout.llb piazzole, fori, etc.  Dip_100b.llb integrati piazzole rettang. 
Tm_axial.llb assiali (per le resistenze)  Dip_100t.llb integrati piazzole tonde 
Tm_cylnd.llb cilindrici (led, condens.)  To.llb a tre pin  (transistori) 
Tm_rad.llb parallelepipedi (c.plastici)  Vres.llb trimmer 
Tm_disc.llb (per condens. Ceramici)  Jumper.llb ponti (per monofaccia) 
Tm_diode.llb diodi con pin number A,C  Padstack.llb piazzole per nuovi footprint 
Tm_cap_p.llb condensatori con pin P,N  Relay.llb relè vari 
N.B.: lo scrivente ha realizzato una nuova libreria chiamata LayLib.llb che contiene i     
         jumper ed alcuni componenti con piazzole allargate. 
 
Le strategie di sbroglio. 
La creazione di un nuovo progetto con Layout richiede di scegliere la strategia di sbroglio 
tra quelle contenute in: C:\…….\Orcad\Layout\Data. 
Le strategie presenti (ad esempio default.tch) non sono adatte alla stampa artigianale, 
pertanto si è provveduto a creare due files alternativi che possono essere copiati nella 
cartella “Data” sopra citata ed eventualmente anche nella cartella del nostro progetto. 
SingleLay.tch : basette monofaccia (piste lato BOTTOM) con il minor numero di ponti. 
DoubleLay.tch : basette doppia faccia con meno piste possibile su layer TOP. 
 
In Orcad Layout si lavora in unità di misura inglese cioè in mils: un mils è un millesimo di pollice. 
Tabella di conversione delle unità di lunghezza. 
1000 mils=1 pollice 2,54 cm=25,4 millimetri  39,4 mils 1 millimetro 
100 mils 2,54 millimetri  Convertire in mm  mm = mils / 39,4 
10 mils 0,254 millimetri  Convertire in mils  mils = mm x 39,4 
 
 
Entrare in orcad Layout. 
Dal menù di avvio eseguire il programma 
Layout_Plus. Cliccare su File>New 
(oppure su icona Open_new-board) ed  
aprire il file di strategia (file Technology 
Template) SingleLay.tch oppure 
DoubleLay.tch. 
Ora il programma chiede di aprire il file 
netlist con estensione .mnl 
precedentemente salvato nella nostra 
cartella di lavoro; cliccare su annulla per 
lavorare in modo completamente 
manuale, quest’ultima possibilità viene 
fornita solo da Orcad 9.2 o versioni 
precedenti! 
Dal programma Layout_Plus si va a 
creare un nuovo file con estensione .MAX 
che costituisce il circuito stampato (Board) 



Da CAPTURE a LAYOUT passo dopo passo  8 
 

 
IPSIA "Zanussi" di Pordenone   

I componenti da Capture a Layout. 
Dato che il  programma  deve associare,  ai  componenti  inclusi nella netlist,  i footprint da 
collocare sulla Board (E.C.O.=Automatic Engineering Change Order), compare la finestra 
“Link_Footprint_to_Component” con tre opzioni: la prima opzione chiede di scegliere dalla 
libreria il footprint corrispondente al componente elencato, mentre la seconda opzione 
consente di aprire il sottoprogramma “Library_Manager” per creare nuovi footprint o 
adattare quelli esistenti alle nostre esigenze. 

 
 
E’ necessario scegliere footprint che 
abbiano lo stesso numero di pin del 
componente, ed anche lo stesso nome, 
come detto in precedenza.  
 
 
Al termine dell’operazione comparirà il 
piano di lavoro con tutti i footprint e le 
connessioni da tracciare rappresentate da 
rette gialle (Nets).  
 
 
 
Va detto che Orcad ricorda i collegamenti tra componenti e footprint fatti precedentemente 
anche per progetti diversi da quello attuale. Tali collegamenti vengono memorizzati nel file 
User.prt contenuto nella cartella  C:\..….\Layout\Data. 
 
Opzioni di lavoro. 
Per lavorare con dei riferimenti precisi conviene mantenere visibile la griglia con passo di 
100 mils (pari a 2,54 mm ovvero il passo di un integrato) con Options>System 
Setting>Visible grid[X,Y]: 100 
Sempre dallo stesso menù si possono impostare altri importanti parametri relativi al 
posizionamento dei footprint e delle piste. 
Per limitare il salvataggio automatico del circuito stampato con conseguente creazione di 
numerosi file .MAX andare su Option>Auto_Backup e porre i seguenti valori minimi (già 
inclusi in SingleLay.tch e DoubleLay.tch): 
Backup_Time = 0 
Numbers_of_backup = 1 
Disattivare opzione “Backup_after_each_Sweep” 
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Se sul piano di lavoro compare il cartiglio Drill_Chart, contenuto nel layer DRLDWG, può 
essere nascosto con l’opzione Color_Setting > Default_DRLDWG → Invisible. 
Se lo schermo si sporca mentre lavorate potete ripulirlo con la funzione View>Redraw 
oppure dalla tastiera con il tasto Home. 
Per evitare inutili perdite di tempo, almeno quando si spostano i footprint, conviene 
mantenere disattivata l’icona “Online_DRC” (Design_Rule_Check per la correzione degli 
errori in tempo reale). La funzione Online_DRC agisce dentro il rettangolo tratteggiato che 
si definisce con View>ZoomDRC/Route_Box.  Non è possibile effettuare lo sbroglio 
manuale delle tracce che sbordano dal DRC_Route_Box.  Eventuali segnalazioni di errore 
creati dal DRC (sottili cerchi chiari) possono essere eliminati con l’icona Error_Tool attiva. 
Per ingrandire a tutto schermo un’area di lavoro, bisogna cliccare sull’icona Zoom_All. 
 
Sintesi di tutte le funzioni di ZOOM richiamabili da tastiera e/o icona. 

Funzione Tasto Descrizione 
Zoom DRC B per creare con il mouse il “Route Box” per lo sbroglio 
Zoom Center C centra nel Route Box la zona puntata dal mouse  
Zoom All shift+home adatta il disegno alle dimensioni dello schermo 
Zoom In I ingrandisce il disegno 
Zoom Out O rimpicciolisce il disegno 
Finestra Z fa lo zoom della finestra disegnata con il mouse 
 
Il bordo del circuito stampato e gli obstacle. 
Per definire il bordo del circuito stampato con l’icona 
Obstacle_Tool attiva cliccare sul tasto destro, selezionare 
New ed aprire con il mouse una finestra che delimita il 
circuito stampato, poi fare un click sull’obstacle per 
selezionarlo e dal menù di pop-up entrare in Properties 
per impostare i seguenti parametri: 
Obstalcle_Type = Board_outline 
Obstacle_Layer = Global_Layer 
Width = 20 
 
E’ consigliabile generare la board_outline partendo 
dall’origine del foglio (coordinate X=0, Y=0) per poi estendersi verso destra e verso l’alto. 
Una volta generato un obstacle potete selezionarlo con un click mantenendo premuto il 
tasto Control per accedere al seguente menù di pop-up. 
 

Funzione Tasto Descrizione 
End Command Esc chiude il comando di elaborazione dell’obstacle 
Properties CTRL+E per modificarne le proprietà (si accede anche con doppio click) 
Copy CTRL+C copiare l’obstacle (anche su un altro layer) 
Delete CTRL+X eliminare l’obstacle 
Rotate R ruota l’obstacle di 90 gradi se non impostato altro valore 
Mirror CTRL+M capovolge l’obstacle in modo speculare 
Opposite --- capovolge l’obstacle sul layer opposto 
Move On/Off --- per spostare l’obstacle (anche su altro layer) 
Undo U annulla l’ultima modifica fatta all’ostacle 
Move On/Off col mouse: tenendo premuto il tasto Control cliccare col mouse una volta sull’obstacle, poi 
mollare tutto, ora tenendo premuto il tasto sinistro del mouse e possibile trascinare tutto l’obstacle. 
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Con gli obstacles è possibile definire superfici ramate disegnando il contorno con le 
seguenti proprietà: 
Obstalcle_Type = Copper_Area 
Obstacle_Layer = BOTTOM oppure TOP 
A questo punto cliccare sulla finestra Hatch Pattern per spuntare una delle voci: 
Line = linee parallele (impostare valori numerici compreso Width) 
Cross_Hatching = griglia (impostare valori numerici compreso Width) 
Solid = area completamente piena 
 
I fori di ancoraggio (hole). 
Anche i fori di fissaggio del circuito stampato 
possono essere disegnati come obstacle 
cliccando su New e poi Arc (tasto A), ma è molto 
importante non assegnarli come Board_outline 
(Route-Via Keepout va bene). 
Un altro modo per definire i fori di fissaggio sulla 
board attivare Component_Tool, con il tasto 
destro del mouse optare per New ed alla voce 
Footprint selezionare la libreria Layout.llb e 
quindi scegliere una Mthole. 
 
 
Misurare o quotare le distanze. 
Per misurare le distanze in mils andare su Tool>Measurement>Select_Tool e con il mouse 
evidenziare la distanza da misurare; le quote appaiono sulla parte bassa dello schermo. 
Se invece si vuole inserire e mantenere una quota sul progetto utilizzare 
Tool>Dimension>New. 
 
Cambiare o aggiungere i Footprint. 
E’ possibile cambiare il footprint di un componente in ogni momento cliccandoci sopra 2 
volte con il tasto sinistro del mouse dopo che l’icona Component_Tool è stata attivata. 
Per inserire nuovi footprint, non previsti nello schema elettrico, attivare Component_Tool e 
con il tasto destro del mouse optare per New e agire sulla voce “Footprint” per accedere 
alle librerie. 
 
Sempre col tasto destro del mouse è possibile agire su altre opzioni molto utili: 

Funzione Tasto Descrizione 
Rotate R ruota il footprint di 90 gradi in senso antiorario (*) 
Opposite T capovolge sul layer opposto 
Lock L blocca il footprint che non si vuole spostare. 
Swap Ctrl+W scambia tra loro due footprint o due piedini (leggere sotto) 
 
(*) Per ruotare un obstacle meno di 90 gradi agire su Option>System Setting>Rotation. 
Per posizionare uno o più footprint in modo automatico, bisogna prima selezionarli 
mantenendo premuto il tasto Control e quindi andare su Auto>Place>Components (oppure 
utilizzare i tasti Ctrl+Q). 
 
In molte occasioni, per semplificare lo sbroglio, è opportuno scambiare tra loro due pin di 
un integrato (per esempio gli ingressi di una porta logica). Per fare ciò è necessario 
selezionare l'icona Pin_tool, quindi cliccare col tasto destro sulla pad e selezionare Swap. 
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Analogamente è possibile scambiare due porte uguali. Si seleziona Tool>Gate, poi si 
clicca sul pin della prima porta, tasto destro e Swap ed infine si clicca sulla seconda porta. 
Per aggiornare lo schema elettrico col cambiamento occorre usare Auto>Back_Annotate 
per creare il file .swp   Infine da Capture cliccare su Project Manager>Back_Annotate. 
Lo Swap funziona anche per lo scambio di interi footprint se si attiva il Footprint_Tool. 
 
Piste (tracks) e Nets. 
Prima dello sbroglio è necessario aumentare lo spessore delle piste. Per fare ciò andare 
su View_Spreadsheet>Nets, selezionare col mouse una o più Nets e con tasto destro 
entrare in Properties per inserire gli spessori in mils; valore tipico 32 mils pari a 0,8mm. 
Per selezionare tutte le nets il modo più semplice consiste nel cliccare due volte  
sull’intestazione Width Min_Con_Max della spreadsheet. 
 

 
 
Per modificare le nets separatamente può essere utile individuarne nome e caratteristiche: 
per fare ciò, dal piano di lavoro, cliccare sull’icona Query, poi attivare l’icona 
Connection_Tool e cliccare su una piazzola da collegare. Nella finestra della query 
comparirà il nome della net che si sta manipolando assieme ad altri dati. 
E’ possibile modificare alcune connessioni, cioè le Nets rappresentate con linee gialle, 
senza passare per lo schema elettrico, si può utilizzare l’icona Connection_Tool abbinata 
al menù di pop-up del mouse. Comunque è preferibile sempre introdurre le modifiche 
partendo dallo schema elettrico. 
 
Lo sbroglio automatico parte con 
Auto>Autoroute>Board, e Auto>Unroute> 
Board lo disfa. Invece per disegnare una 
traccia manualmente conviene abilitare 
l’icona “Add/Edit Route Mode” e con il 
menù di pop-up è possibile modificare la 
larghezza (Change_Width). 
L’icona  “Edit Segment Mode”   è  comoda  
per  traslare  segmenti di  traccia già  
esistenti. 
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Le icone “Autopath Route Mode” e “Shove Track Mode” attivano sempre il DRC, perché 
prevedono degli automatismi: la prima realizza la traccia da punto a punto attraverso 
percorsi anche molto contorti, invece la seconda disegna la traccia un pezzo alla volta e 
sposta,  quando possibile,  le tracce preesistenti che sbarrano la strada. 
 
Sintesi dei comandi essenziali del menù di pop-up per il disegno delle tracks. 

Funzione Tasto Descrizione 
End Command Esc chiude il comando di elaborazione della traccia 
Unroute Segment G disfa progressivamente un segmento alla volta della traccia 
Unroute D disfa tutta la traccia da piazzola a piazzola 
Unroute Net ALT+D disfa tutte le tracce che fanno parte della stessa net 
Segment S per traslare un segmento (simile ad icona edit segment mode) 
Exchange Ends X cambia punto di partenza della traccia da costruire 
Change Width W per cambiare larghezza alla parte di traccia da costruire 
Add Via V per aggiungere una via (poi bisogna cambiare layer) 
Add Free Via E aggiungere via svincolata (non serve cambiare layer) 
Add Test Point P Inserisce un Test Point se nella spreadsheet è configurato 
Lock L blocca una traccia (l’autoroute e l’unroute non la modificano) 
 
Per cambiare rapidamente layer conviene utilizzare i numeri della tastiera. 
Per incurvare le tracce, durante lo sbroglio manuale, entrare in Options>Route_Settings e 
nel riquadro “Manual_Route_Settings” attivare l’opzione Curve_Corners. 
Dopo lo sbroglio è possibile controllare i parametri del circuito ed eventuali errori o 
dimenticanze con View_Spreadsheet>Statistics. L’aggiornamento delle statistiche si 
ottiene quando si attiva il Design_Rule_CkecK. 
 

Piazzole (padstacks). 
Per modificare le dimensioni delle piazzole conviene sempre utilizzare Library_Manager; 
in alternativa bisogna selezionare il footprint da modificare (in realtà tutti i footprint con lo 
stesso nome presenti sulla basetta subiranno il cambiamento). Per selezionare un 
footprint senza correre il rischio di trascinarlo premere il tasto Control. A questo punto 
andare su View>Database_Spreadsheet>Padstacks dove visualizzerete, già selezionato, 
il tabulato delle piazzole; cliccare sulla casella Bottom→Properties dove potete modificare 
lo Shape cioè la forma, la larghezza e l’altezza delle piazzole. 
 

Le Via. 
Le via sono le piazzole utilizzate per unire tra loro le tracce sui lati  opposti nei circuiti a 
doppia faccia.  Con Orcad è possibile definire diversi tipi di via andando su 
View_Spreadsheet>Padstacks. 
Nei files di strategia SingleLay.tch e DoubleLay.tch sono definite due via: la prima da 86 
mils e la seconda da 100 mils. Con SingleLay.tch le via non hanno senso, perché si lavora 
in monofaccia, ma possono essere inserite le Free_vias come piazzole supplementari 
Durante lo sbroglio le via sono considerate alla stregua di tracce e non di piazzole; con lo 
sbroglio manuale di una traccia le via possono essere inserite premendo il tasto “V”, ma 
possono essere collocate anche autonomamente da Orcad quando la traccia incontra uno 
sbarramento oppure si prosegue sul layer opposto. 
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Test Point. 
Per poter usufruire dei Test Point è indispensabile definire la pad nell’elenco della 
spreadsheet subito dopo le via.  Nei files SingleLay.tch e DoubleLay.tch di strategia è 
stata definita una pad di Test Point quadrata con lato di 120 mils. e priva di foro. 
Il Test Point può essere inserito dal menù di pop-up durante lo sbroglio di una traccia. 
 

Ponti (Jumper). 
Se lavorate in monofaccia potete convertire le piste celesti in Jumper (ponti) a patto che 
abbiate caricato la libreria Jumper.llb o meglio LayLib.llb contenente i ponti con le piazzole 
allargate e che le lunghezze siano standard:  Tool>Jumper>Convert_to_Components. 
Se al posto del Jumper (inteso come componente) compare una segnalazione di errore 
controllare Spreadsheets>Layers>TopJumpers→Properties>Jumper_Attributes. 
Dopo tale conversione potete spostare i ponti che si sovrappongono ad altri componenti; 
per selezionare un jumper andare su Tool>Jumper>Select Tool. 
Le piste e piazzole celesti prima di essere convertite in Jumper possono comunque essere 
modificate agendo sul layer TOP con l’icona “Edit_segment_mode” attiva. 
Analogamente, si possono creare nuovi ponti in modo manuale generando le tracce dritte 
sul layer TOP.    Se operate in doppia faccia i ponti non saranno abilitati. 
 
Testi 
Per aggiungere dei testi sul circuito stampato (sigle, indicazioni per il cablaggio, etc.) 
attivare l’icona Text_Tool e con il tasto destro cliccare su New; se il testo va inserito sul 
layer BOTTOM è importante attivare la funzione Mirrored per non visualizzarlo alla 
rovescia sulla basetta finale. 
 
Operazioni conclusive: rifiniture sbroglio, controllo errori e lista componenti. 
Dopo lo sbroglio del circuito stampato è possibile avviare un automatismo che ne migliora 
l’aspetto ricorrendo al menù Auto>Cleanup_Design. Per eliminare l’ultima modifica 
utilizzare sempre il tasto “U”. 
 
Per effettuare un controllo di eventuali errori attivare Auto>Design_Rule_Check e spuntare 
il tipo di errori da segnalare. E’ possibile usare anche l’icona Design_Rule_Check che 
tuttavia non consente di modificare alcuna impostazione. 
Per interrogare la lista degli errori andare su Tool>Error>Select_from_spreadsheet 
 
Per vedere ed eventualmente stampare l’elenco di tutti i componenti del circuito stampato 
(reference e valore inseriti con Capture nonché il nome dei package e dei footprint) andare 

su Auto>Create_Reports e 
da menù spuntare Comp_All 
e View_Report >OK. 
Naturalmente è possibile 
vedere anche altri tipi di 
reports come la netlist o il 
drill della foratura. 
 
Stampare i layer 
Con Layout si può avere la 
stampa direttamente su carta 
dei singoli layer o generare 
dei files Gerber (utilizzati 
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dalle aziende di stampa dei circuiti) o files .dxf compatibili con AutoCAD. 
La veduta d’insieme del circuito può essere modificata con l’icona Color_Setting che 
consente di eliminare o aggiungere layer o modificarne i colori a piacere. 
Un modo molto rapido per cambiare il settaggio dei colori è quello di caricare uno dei files 
che sono stati creati su misura per le comuni esigenze di stampa artigianale. 
Per il caricamento andare su File>Load, sulla riga “Tipo di file” optare per Color_Setup ed 
aprire uno dei seguenti files: 
 
Bottom.col  per la stampa in nero del piano ramato principale 
Top.col     per la stampa in nero della seconda faccia ramata 
SSTOP.col  per la stampa in nero del piano con i componenti 
S+Val+Pad  per la stampa del piano componenti con il loro valore e le loro pad 
Drill.col  per la stampa del piano di foratura 
Default.col  per ripristinare i colori iniziali di progetto 
 
N.B.: tali files sono stati creati con File>Save_As, quindi  Salva come:  Color_Setup 
 
Per stampare tale veduta andare su File>Print/Plot da dove attivare: 
Print_Manager 
Keep_Drill_Holes_Open per stampare le piazzole con il forellino  
Force_Black&White per eliminare i colori ed aumentare il contrasto 
Center_on_Page se volete stampare in centro pagina 
Concludere con OK. 
Attivate anche la funzione Mirror (speculare) per stampare, ad esempio il master del layer 
BOTTOM per la fotoincisione con vista dal lato rame. 

Un altro modo per vedere (ed 
eventualmente stampare) un 
singolo Layer è di andare su 
Options>Post_Process_Setting, 

selezionare una riga e fare il 
Preview con il tasto destro del 
mouse. Si ricorda che l’icona 
Color_Setting è sempre attiva. 
Usare Window>Tile per 
affiancare le finestre, mentre per 
tornare alla videata principale di 
layout conviene usare il 
comando Window>Reset_All. 

 
 

Library Manager di Orcad Layout.         .  
 
E’ un sottoprogramma integrato in Layout; può essere richiamato dall’omonima icona 
durante il progetto di un circuito stampato, oppure subito dopo l’avvio di Layout, dal menù 
Tools>Library_Manager. 
Da qui è possibile creare un nuovo componente o più semplicemente modificarne uno 
preesistente. Con l’opzione Save_As.. è possibile salvare il nostro componente su una 
libreria esistente o su una libreria che andiamo a creare con Create_New_Library. 
Ogni componente, detto footprint, è caratterizzato da una serie di pin con le relative 
piazzole (padstacks), e da un contenitore (package). Il package a sua volta è circondato 
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dal case costituito da una linea sottile (outline) che ne definisce l’ingombro e serve ad 
evitare la sovrapposizione dei footprint nel circuito stampato. 
Al momento è stata creata una libreria di nome LayLib.llb con alcuni footprint 
ridimensionati per la stampa artigianale (piazzole allargate). Per poter accedere a tale 
libreria bisogna utilizzare preventivamente l’opzione “Add” di Library_Manager per 
aggiornare l’elenco contenuto nel file C:\……..\Layout\Layout.ini (file che non deve essere 
protetto dalla scrittura!). 
La libreria LayLib.llb contiene i footprint dei circuiti integrati con pad larghe 56 mils per 
tracce da 32 mils, ed ancora footprint con pad da 70 mils per poter interporre una traccia 
da 24 mils. I footprint assiali (resistori) o parallelepipedi (condensatori plastici) che hanno 
pad da 86 mils possono essere affiancati tra loro con passo di 100 mils. 
Tutto ciò perché l’isolamento previsto dalle strategie di sbroglio è di almeno14 mils! 
 
Creare nuovi footprint. 
Per creare un nuovo componente da Library Manager andare in Option_System_Setting 
ed impostare i seguenti parametri: 
Visible grid [X,Y] = 50    la distanza tra i punti di riferimento è di 50 mils 
Detail grid [X,Y] = 5  gli Obstacles (linee, archi, etc.) lavorano su griglia di 5 mils 
Place grid [X,Y] = 25 le piazzole possono essere posizionate su griglia da 25 mils 
Routing grid [X,Y] = 25 le tracce si posizionano su griglia da 25 mils 
Sempre da Library_Manager cliccare sulla finestra “Create_New_Footprint”, digitare un 
nome adeguato, attivare le unità di misura inglesi e dare l’OK. 
Inserire le piazzole con l’icona Pin_Tool attiva; è bene non spostare la piazzola numero 1 
già presente sull’origine (l’origine è sempre visibile dopo aver premuto il tasto Home). Per 
modificare forma e dimensioni di una piazzola fare doppio click su di essa. A questo punto 
scegliere la piazzola dall’elenco Padstack_Name attingendo soprattutto alla libreria 
Padstack.llb; qui troverete ad esempio la piazzola 80R60 dove 80 indica le dimensioni in 
mils della piazzola di rame e R ne specifica la forma rotonda (al contrario S=square ovvero 
quadrata), 60 è il diametro del foro. Dallo stesso menù attivare l’opzione “Any_direction” 
se si vuole che le tracce possano provenire da tutte le direzioni (opzione attiva sui DIP da 
70 mils in LayLib.llb). Altre modifiche alla pad prescelta, dopo averla selezionata, si 
possono fare da View_Spreadsheets>Padstacks; ad esempio per le pad dei display sono 
state attivate le opzioni non_plated (fori non metallizzati) e no_connection nel layer TOP. 
Una pad modificata in forma e dimensioni può essere collocata nella libreria Padstack.llb 
usando l’opzione “Save_to_Library” del menù di pop-up sulla Spreadsheet. 
Per disegnare il package attivare l’icona Obstacle_Tool>New; per accedere alle sue 
proprietà cliccare due volte sul nuovo obstacle: 
Type=Detail,        Width=8,        Obstacle_layer=Global_Layer. 
Selezionare l’obstacle appena creato con una finestra tutta intorno oppure cliccandolo 
mentre il tasto Control è premuto, dal menù di pop_up attivate Copy, portatevi sul layer  
AsyTop e sovrapponete i due package 
Il “case” che rappresenta l’ingombro del componente per evitare sovrapposizioni con altri 
footprint, deve essere almeno 5 mils più grande del package. Esso è un obstacle molto 
sottile (1mils) di tipo “place_outline” e va collocato sul layer globale. 
Si ricorda che il Layer che ci interessa per la stampa dei componenti è SSTOP (serigrafia) 
ed è bianco, mentre il layer ASYTOP (assembly TOP) in verde è poco rilevante. 
Per poter ruotare un obstacle meno di 90 gradi agire su Option>System_Setting>Rotation. 
Per creare un package a forma di cerchio smussato (ad esempio vedi i LED di LayLib.llb) 
bisogna creare prima il segmento, poi selezionarlo con un click, ed infine dal menù di pop-
up creare l’arco (tasto “A”). 
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Per controllare gli obstacles appena disegnati cliccare su View>Database 
Spreadsheet>Obstacles; si dovrebbero vedere i parametri come da tabella sottostante ed 
in particolare i due obstacles con le stesse caratteristiche stanno in SSTOP e ASYTOP. 
 

Width or Eight Obstacle Type Layer  Commento 
1 Place outline Global Layer  Linea sottile verde, definisce l’ingombro 

8 Detail SSTOP  Package visibile su Layer SSTOP 

8 Detail ASYTOP  Package visibile su Layer ASYTOP 

 
Con l’icona Text_Tool attiva potete cancellare l’indicazione &Pack (nome del Package) e 
potete spostare le altre scritte per ridurre le sovrapposizioni. 
Il testo in bianco sta sul layer SSTOP (quello che ci interessa per la stampa del layer 
componenti), mentre le scritte verdi stanno su ASYTOP. 
 
Modificare un footprint per le librerie. 
Per modificare il package di un footprint esistente conviene cancellare preventivamente 
l’obstacle ASYTOP ed il global_layer dalla spreadsheet per intervenire isolatamente sul 
case del layer SSTOP; infine si aggiungeranno gli obstacles mancanti come già visto per 
la creazione di nuovi footprint. Il salvataggio può essere fatto assegnando un nuovo nome 
con “Save_As…”, se invece si utilizza “Save”  si modifica il footprint di partenza. 
 

          Appendice.          .  
 
Le estensioni dei files di Capture. 
.opj File di progetto da conservare; cliccarlo per aprire il progetto (icona con cartella celeste) 
.dsn File disegno da conservare pena la perdita dello schema elettrico (icona mappamondo) 
.olb Librerie di Capture 
.sch File di schema di lavori progettati con la obsoleta versione di Orcad SDT. 
.drc Design_Rules_Check ovvero rapporto sugli errori del disegno 
.xrf Cross_Reference_Part 
.bom Bill_of_materials è un file di testo che costituisce l’elenco componenti 
.swp Back_Annotate per trasferire eventuali correzioni-modifiche da Layout a Capture 
 
Le estensioni dei files di Layout. 
.mnl File netlist con tutti i componenti e le connessioni generate con Orcad Capture 
.tpl Template file (regole di progetto) 
.tch Technology_Template file (strategie + outline)…ad esempio Default.tch lavora su 4 
           strati. Le track (piste) sono da 12 mils, le Pad da 62 mils a lo Spacing di 12 mils. 
.sf Strategie di sbroglio (per default viene caricato STD.sf). 
.max File binario essenziale che racchiude il circuito stampato (icona rossa-grigia con PCB) 
.err Rapporto degli errori generato dall’AutoEco (Automatic Engineering Change Order)  
           che deriva dalla combinazione del technology_template con la netlist. 
.llb Librerie dei footprint con il loro package 
.swp Back_annotate per trasferire le modifiche di Layout in Capture 
.dxf File compatibile con AutoCAD 
.log Testo con rapporto delle operazioni svolte, utile per eventuale assistenza tecnica. 
 
File di sistema. 
Per poter modificare l’elenco delle librerie di Orcad che vengono di volta in volta caricate è 
necessario poter modificare, e quindi non proteggere dalla scrittura, i files Capture.ini, Pspice.ini e 
soprattutto Layout.ini contenuti nelle cartelle omonime. 
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Il file C:\……\Layout\Data\User.prt ricorda le associazioni create tra i componenti di Capture e 
quelli di Layout. 
 
Glossario.  
 
ECO Automatic_Engineering_Change_Order è l’automatismo che consente il passaggio 

da Orcad Capture a Layout. 
Tracks Tracce ovvero le piste del circuito stampato; una track può essere composta da più 

segments 
Footprint Foot=piede è la piedinatura di un componente di Layout. In generale tuttavia con il 

termine Footprint si intende l’intero componente di Layout 
Packages E’ il disegno del contenitore fisico del componente 
Case E’ una linea sottile che definisce l’ingombro del componente 
Layer  Lato ovvero strato 
Padstacks Piazzole 
Tile  Si pronuncia tail ed è un comando che adatta ed affianca le finestre attive 
Spreadsheet    Si legge spredscit e vuol dire pila di foglietti. 
 
OBSTACLE Si pronuncia abstacl e significa ostacolo. Con gli obstacles si definiscono i bordi del 

circuito (global_layer cioè passanti), zone proibite, zone ramate, etc. 
BOTTOM  In rosso costituisce il layer principale delle tracce di rame; quando la stampa è 

destinata alla fotoincisione della basetta deve essere attivata la funzione mirror 
(speculare). 

TOP In celeste rappresenta il secondo lato delle tracce di rame e si utilizza per basette in 
doppia faccia; nelle basette monofaccia il layer TOP riporterà i ponti prima che 
vengano convertiti in componenti. 

SSTOP Silkscreen (serigrafia); in bianco riporta il package dei componenti e il reference ad 
essi assegnato. 

ASYTOP Assembly_TOP in verde riporta generalmente il package, il reference, il valore ed il 
nome dei componenti; informazioni aggiuntive di scarsa utilità rendono l’ASYTOP  
meno leggibile dell’SSTOP,  quindi meglio nasconderlo. 

INNER Strati interni delle tracce di rame; possono arrivare a 12. 
GND Ground plane ovvero piano di massa. 
PWR Power plane o piano delle alimentazioni. 
SMT/SMB Solder mask TOP o BOTTOM ovvero maschera del solder. 
SPT/SPB Solder paste TOP o BOTTOM ovvero pasta salda. 
DRLDWG Drill drawing ovvero piano di foratura. 
DRL Drill, informazioni di foratura per generare il file Excellon. 
 
Programmi supplementari di Orcad 10.3 
 
INTELLICAD: è un programma che gestisce i disegni vettoriali con estensione .dxf in modo del 

tutto simile ad AutoCAD. Se con Orcad Layout si accede al menù di stampa di un 
layer si può generare un  file .dxf  riconoscibile da Intellicad. 

 
SPECCTRA:  è un programma che possiede funzioni di sbroglio automatico più avanzate di 

Layout. Da quest’ultimo bisogna accedere all’utility con Auto>Autoroute>Specctra 
che genera un file con estensione .do compatibile col programma Specctra che 
potrà essere aperto dal menù di avvio dei programmi. 

 

Guida realizzata a cura del prof. Giulio Caramazza 
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